$re = '/(<item>[^<]*?<title>(?<title>[^<]*?)<\/title>([^<]|<(?!description))*<description>(?<desc>[^<]*?keyword[^<]*?)<\/description>[^<]*?<\/item>)/s';
$str = '<item>
<title>bla</title>
...
<description>bla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<summary>bla2</summary>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
<item>
<title>bla2</title>
....
<description>no kword here</description>
</item>
blablabla
<item>
<title>bla</title>
...
<description>bla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);