import Foundation
let pattern = #"(<item>[^<]*?<title>(?<title>[^<]*?)<\/title>([^<]|<(?!description))*<description>(?<desc>[^<]*?keyword[^<]*?)<\/description>[^<]*?<\/item>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<item>
<title>bla</title>
...
<description>bla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<summary>bla2</summary>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
<item>
<title>bla2</title>
....
<description>no kword here</description>
</item>
blablabla
<item>
<title>bla</title>
...
<description>bla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
<item>
<title>bla2</title>
<summary>bla2</summary>
<description>bla2, keyword here are blablabla</description>
</item>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)