import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<item>[^<]*?<title>(?<title>[^<]*?)<\\/title>([^<]|<(?!description))*<description>(?<desc>[^<]*?keyword[^<]*?)<\\/description>[^<]*?<\\/item>)";
final String string = "<item>\n"
+ "<title>bla</title>\n"
+ "...\n"
+ "<description>bla</description>\n"
+ "</item>\n\n\n"
+ "<item>\n"
+ "<title>bla2</title>\n"
+ "<summary>bla2</summary>\n"
+ "<summary>bla2</summary>\n"
+ "<summary>bla2</summary>\n"
+ "<description>bla2, keyword here are blablabla</description>\n"
+ "</item>\n\n"
+ "<item>\n"
+ "<title>bla2</title>\n"
+ "....\n"
+ "<description>no kword here</description>\n"
+ "</item>\n\n"
+ "blablabla\n\n"
+ "<item>\n"
+ "<title>bla</title>\n"
+ "...\n"
+ "<description>bla</description>\n"
+ "</item>\n\n"
+ "<item>\n"
+ "<title>bla2</title>\n"
+ "<summary>bla2</summary>\n"
+ "<description>bla2, keyword here are blablabla</description>\n"
+ "</item>\n\n"
+ "<item>\n"
+ "<title>bla2</title>\n"
+ "<summary>bla2</summary>\n"
+ "<description>bla2, keyword here are blablabla</description>\n"
+ "</item>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}