# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<item>[^<]*?<title>(?<title>[^<]*?)<\/title>([^<]|<(?!description))*<description>(?<desc>[^<]*?keyword[^<]*?)<\/description>[^<]*?<\/item>)"
test_str = ("<item>\n"
"<title>bla</title>\n"
"...\n"
"<description>bla</description>\n"
"</item>\n\n\n"
"<item>\n"
"<title>bla2</title>\n"
"<summary>bla2</summary>\n"
"<summary>bla2</summary>\n"
"<summary>bla2</summary>\n"
"<description>bla2, keyword here are blablabla</description>\n"
"</item>\n\n"
"<item>\n"
"<title>bla2</title>\n"
"....\n"
"<description>no kword here</description>\n"
"</item>\n\n"
"blablabla\n\n"
"<item>\n"
"<title>bla</title>\n"
"...\n"
"<description>bla</description>\n"
"</item>\n\n"
"<item>\n"
"<title>bla2</title>\n"
"<summary>bla2</summary>\n"
"<description>bla2, keyword here are blablabla</description>\n"
"</item>\n\n"
"<item>\n"
"<title>bla2</title>\n"
"<summary>bla2</summary>\n"
"<description>bla2, keyword here are blablabla</description>\n"
"</item>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.