#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}(?:\.\d{1,3}){2}\.(?:1\d+|[02-9]\d*)$"
Local $sString = "192.168.1.1" & @CRLF & _
"192.168.20.1" & @CRLF & _
"192.168.30.1" & @CRLF & _
"but should not discard" & @CRLF & _
"192.168.1.101" & @CRLF & _
"192.168.20.103"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")