import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,3}(?:\\.\\d{1,3}){2}\\.(?:1\\d+|[02-9]\\d*)$";
final String string = "192.168.1.1\n"
+ "192.168.20.1\n"
+ "192.168.30.1\n"
+ "but should not discard\n"
+ "192.168.1.101\n"
+ "192.168.20.103";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}