use strict;
my $str = '192.168.1.1
192.168.20.1
192.168.30.1
but should not discard
192.168.1.101
192.168.20.103';
my $regex = qr/^\d{1,3}(?:\.\d{1,3}){2}\.(?:1\d+|[02-9]\d*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}