const regex = /^\d{1,3}(?:\.\d{1,3}){2}\.(?:1\d+|[02-9]\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,3}(?:\\.\\d{1,3}){2}\\.(?:1\\d+|[02-9]\\d*)$', 'gm')
const str = `192.168.1.1
192.168.20.1
192.168.30.1
but should not discard
192.168.1.101
192.168.20.103`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}