re = /^\d{1,3}(?:\.\d{1,3}){2}\.(?:1\d+|[02-9]\d*)$/m
str = '192.168.1.1
192.168.20.1
192.168.30.1
but should not discard
192.168.1.101
192.168.20.103'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end