package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,3}(?:\.\d{1,3}){2}\.(?:1\d+|[02-9]\d*)$`)
var str = `192.168.1.1
192.168.20.1
192.168.30.1
but should not discard
192.168.1.101
192.168.20.103`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}