#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(?:[A-Za-z\.#\*]))((?<=(?:[\s])|(?<=^)))[a-z-\[\]:{1,2}#\.\*]+(\s+)?{"
Local $sString = "custom {" & @CRLF & _
"}" & @CRLF & _
"custom {" & @CRLF & _
"}" & @CRLF & _
"custom-tag.lol {" & @CRLF & _
"}" & @CRLF & _
"custom-tag[lol] {" & @CRLF & _
"}" & @CRLF & _
"custom-tag:active {" & @CRLF & _
"}" & @CRLF & _
"custom-tag::after {" & @CRLF & _
"}" & @CRLF & _
".lol {" & @CRLF & _
" custom-tag {" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"[a-z-\[\]:{1,2}#\.\*]+(\s+)?{" & @CRLF & _
"(?(?=\w) (?<!\w) | (?<!\W) )" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")