re = /(?=(?:[A-Za-z\.#\*]))((?<=(?:[\s])|(?<=^)))[a-z-\[\]:{1,2}#\.\*]+(\s+)?{/m
str = 'custom {
}
custom {
}
custom-tag.lol {
}
custom-tag[lol] {
}
custom-tag:active {
}
custom-tag::after {
}
.lol {
custom-tag {
}
}
[a-z-\\[\\]:{1,2}#\\.\\*]+(\\s+)?{
(?(?=\\w) (?<!\\w) | (?<!\\W) )
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end