import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:[A-Za-z\\.#\\*]))((?<=(?:[\\s])|(?<=^)))[a-z-\\[\\]:{1,2}#\\.\\*]+(\\s+)?\\{";
final String string = "custom {\n"
+ "}\n"
+ "custom {\n"
+ "}\n"
+ "custom-tag.lol {\n"
+ "}\n"
+ "custom-tag[lol] {\n"
+ "}\n"
+ "custom-tag:active {\n"
+ "}\n"
+ "custom-tag::after {\n"
+ "}\n"
+ ".lol {\n"
+ " custom-tag {\n"
+ " }\n"
+ "}\n\n"
+ "[a-z-\\[\\]:{1,2}#\\.\\*]+(\\s+)?{\n"
+ "(?(?=\\w) (?<!\\w) | (?<!\\W) )\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}