using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:[A-Za-z\.#\*]))((?<=(?:[\s])|(?<=^)))[a-z-\[\]:{1,2}#\.\*]+(\s+)?{";
string input = @"custom {
}
custom {
}
custom-tag.lol {
}
custom-tag[lol] {
}
custom-tag:active {
}
custom-tag::after {
}
.lol {
custom-tag {
}
}
[a-z-\[\]:{1,2}#\.\*]+(\s+)?{
(?(?=\w) (?<!\w) | (?<!\W) )
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}