import Foundation
let pattern = ##"(?=(?:[A-Za-z\.#\*]))((?<=(?:[\s])|(?<=^)))[a-z-\[\]:{1,2}#\.\*]+(\s+)?{"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
custom {
}
custom {
}
custom-tag.lol {
}
custom-tag[lol] {
}
custom-tag:active {
}
custom-tag::after {
}
.lol {
custom-tag {
}
}
[a-z-\[\]:{1,2}#\.\*]+(\s+)?{
(?(?=\w) (?<!\w) | (?<!\W) )
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)