# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+?)\s*{?\s*(.+?;)\s*}?\s*/$1 {\n\t$2\n}\n/g;t' <<< "if (KnR)
foo();
if (spaces) {
foo();
}
if (allman)
{
foo();
}
if (horstmann)
{ foo();
}
if (pico)
{ foo(); }
if (whitesmiths)
{
foo();
}"