import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?)\\s*\\{?\\s*(.+?;)\\s*\\}?\\s*";
final String string = "if (KnR)\n"
+ " foo();\n"
+ "if (spaces) {\n"
+ " foo();\n"
+ "}\n"
+ "if (allman)\n"
+ "{\n"
+ " foo();\n"
+ "}\n"
+ "if (horstmann)\n"
+ "{ foo();\n"
+ "}\n"
+ "if (pico)\n"
+ "{ foo(); }\n"
+ "if (whitesmiths)\n"
+ " {\n"
+ " foo();\n"
+ " }";
final String subst = "$1 {\\n\\t$2\\n}\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}