re = /(.+?)\s*{?\s*(.+?;)\s*}?\s*/
str = 'if (KnR)
foo();
if (spaces) {
foo();
}
if (allman)
{
foo();
}
if (horstmann)
{ foo();
}
if (pico)
{ foo(); }
if (whitesmiths)
{
foo();
}'
subst = '$1 {\\n\\t$2\\n}\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result