#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.+?)\s*{?\s*(.+?;)\s*}?\s*"
Local $sString = "if (KnR)" & @CRLF & _
" foo();" & @CRLF & _
"if (spaces) {" & @CRLF & _
" foo();" & @CRLF & _
"}" & @CRLF & _
"if (allman)" & @CRLF & _
"{" & @CRLF & _
" foo();" & @CRLF & _
"}" & @CRLF & _
"if (horstmann)" & @CRLF & _
"{ foo();" & @CRLF & _
"}" & @CRLF & _
"if (pico)" & @CRLF & _
"{ foo(); }" & @CRLF & _
"if (whitesmiths)" & @CRLF & _
" {" & @CRLF & _
" foo();" & @CRLF & _
" }"
Local $sSubst = "$1 {\n\t$2\n}\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)