use strict;
my $str = 'if (KnR)
foo();
if (spaces) {
foo();
}
if (allman)
{
foo();
}
if (horstmann)
{ foo();
}
if (pico)
{ foo(); }
if (whitesmiths)
{
foo();
}';
my $regex = qr/(.+?)\s*{?\s*(.+?;)\s*}?\s*/p;
my $subst = '$1 {\\n\\t$2\\n}\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";