using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)\s*{?\s*(.+?;)\s*}?\s*";
string substitution = @"$1 {\n\t$2\n}\n";
string input = @"if (KnR)
foo();
if (spaces) {
foo();
}
if (allman)
{
foo();
}
if (horstmann)
{ foo();
}
if (pico)
{ foo(); }
if (whitesmiths)
{
foo();
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}