#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\*)\*\*([^*\\\n]*(?:\\.[^*\\\n]*)*)\*\*(?!\*)"
Local $sString = "**abc*def***" & @CRLF & _
"**abc*def**" & @CRLF & _
"**abc\*def\***" & @CRLF & _
"**abc def**"
Local $sSubst = "*\1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)