$re = '/(?<!\*)\*\*([^*\\\\\n]*(?:\\\\.[^*\\\\\n]*)*)\*\*(?!\*)/m';
$str = '**abc*def***
**abc*def**
**abc\\*def\\***
**abc def**';
$subst = "*\1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;