import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\*)\\*\\*([^*\\\\\\n]*(?:\\\\.[^*\\\\\\n]*)*)\\*\\*(?!\\*)";
final String string = "**abc*def***\n"
+ "**abc*def**\n"
+ "**abc\\*def\\***\n"
+ "**abc def**";
final String subst = "*\\1*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}