import re
regex = re.compile(r"(?<!\*)\*\*([^*\\\n]*(?:\\.[^*\\\n]*)*)\*\*(?!\*)", flags=re.MULTILINE)
test_str = ("**abc*def***\n"
"**abc*def**\n"
"**abc\\*def\\***\n"
"**abc def**")
subst = "*\\1*"
result = regex.sub(subst, test_str)
if result:
print(result)