package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*ga/([^/$]*)\${4}.*`)
var str = `gs://analytics_models_from_g_rdd_ga/9g653798d-7e13-4238-55443-6db72ace9911$$$$events_today.csv`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}