import re
regex = re.compile(r".*ga/([^/$]*)\${4}.*", flags=re.MULTILINE)
test_str = "gs://analytics_models_from_g_rdd_ga/9g653798d-7e13-4238-55443-6db72ace9911$$$$events_today.csv"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)