const regex = new RegExp('.*ga/([^/$]*)\\${4}.*', 'gm')
const str = `gs://analytics_models_from_g_rdd_ga/9g653798d-7e13-4238-55443-6db72ace9911\$\$\$\$events_today.csv`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);