using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(#?[0-9]{4})";
string input = @".discrim #3333
.discrim 3333
.discrim 3333#
.discrim 3#333
.discrim #33333
.discrim #49275555
.discrim 37583875
.discrim #%$%f334f34f5545 5555
.discrim #5434foijofesrjg gjfi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}