import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(#?[0-9]{4})";
final String string = ".discrim #3333\n"
+ ".discrim 3333\n"
+ ".discrim 3333#\n"
+ ".discrim 3#333\n"
+ ".discrim #33333\n"
+ ".discrim #49275555\n"
+ ".discrim 37583875\n"
+ ".discrim #%$%f334f34f5545 5555 \n"
+ ".discrim #5434foijofesrjg gjfi";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}