// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(#?[0-9]{4})").unwrap();
let string = ".discrim #3333
.discrim 3333
.discrim 3333#
.discrim 3#333
.discrim #33333
.discrim #49275555
.discrim 37583875
.discrim #%$%f334f34f5545 5555
.discrim #5434foijofesrjg gjfi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}