$re = '/\b(#?[0-9]{4})/m';
$str = '.discrim #3333
.discrim 3333
.discrim 3333#
.discrim 3#333
.discrim #33333
.discrim #49275555
.discrim 37583875
.discrim #%$%f334f34f5545 5555
.discrim #5434foijofesrjg gjfi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);