const regex = /\b(#?[0-9]{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(#?[0-9]{4})', 'gm')
const str = `.discrim #3333
.discrim 3333
.discrim 3333#
.discrim 3#333
.discrim #33333
.discrim #49275555
.discrim 37583875
.discrim #%\$%f334f34f5545 5555
.discrim #5434foijofesrjg gjfi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}