using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bSFP-[0-9]{5}\b";
string input = @"1fb99f55 SFP-24576: If Fulfiller gwVersion=4.0, then do not convert order to v3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}