const regex = /\bSFP-[0-9]{5}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bSFP-[0-9]{5}\\b', 'g')
const str = `1fb99f55 SFP-24576: If Fulfiller gwVersion=4.0, then do not convert order to v3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}