re = /\bSFP-[0-9]{5}\b/
str = '1fb99f55 SFP-24576: If Fulfiller gwVersion=4.0, then do not convert order to v3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end