import re
regex = re.compile(r"\bSFP-[0-9]{5}\b")
test_str = "1fb99f55 SFP-24576: If Fulfiller gwVersion=4.0, then do not convert order to v3"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")