using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^{}]+{";
string input = @".match_num {
font-family: futura, helvetica, arial;
font-variant: small-caps;
color: #84BDE7;
color: #0066B3;
font-size: 12px;
font-weight: normal;
display: inline-block;
}
.match0,.match1,.match2,.match3,.match4,.match5,.match6,.match7,.match8,.match9,.match10,.match11 {
white-space: pre-wrap;
font-size: 12px;
padding: 1px 2px;
}
.backref_hover {
cursor: help;
}
input {
blah: blah;
}
.stuff {
problem: here;
}
.hello
{
whatever
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}