re = /^[^{}]+{/m
str = '.match_num {
font-family: futura, helvetica, arial;
font-variant: small-caps;
color: #84BDE7;
color: #0066B3;
font-size: 12px;
font-weight: normal;
display: inline-block;
}
.match0,.match1,.match2,.match3,.match4,.match5,.match6,.match7,.match8,.match9,.match10,.match11 {
white-space: pre-wrap;
font-size: 12px;
padding: 1px 2px;
}
.backref_hover {
cursor: help;
}
input {
blah: blah;
}
.stuff {
problem: here;
}
.hello
{
whatever
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end