use strict;
my $str = '.match_num {
font-family: futura, helvetica, arial;
font-variant: small-caps;
color: #84BDE7;
color: #0066B3;
font-size: 12px;
font-weight: normal;
display: inline-block;
}
.match0,.match1,.match2,.match3,.match4,.match5,.match6,.match7,.match8,.match9,.match10,.match11 {
white-space: pre-wrap;
font-size: 12px;
padding: 1px 2px;
}
.backref_hover {
cursor: help;
}
input {
blah: blah;
}
.stuff {
problem: here;
}
.hello
{
whatever
}';
my $regex = qr/^[^{}]+{/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}