import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\{\\}]+\\{";
final String string = ".match_num {\n"
+ " font-family: futura, helvetica, arial;\n"
+ " font-variant: small-caps;\n"
+ " color: #84BDE7;\n"
+ " color: #0066B3;\n"
+ " font-size: 12px;\n"
+ " font-weight: normal;\n"
+ " display: inline-block;\n"
+ "}\n\n"
+ ".match0,.match1,.match2,.match3,.match4,.match5,.match6,.match7,.match8,.match9,.match10,.match11 {\n"
+ " white-space: pre-wrap;\n"
+ " font-size: 12px;\n"
+ " padding: 1px 2px;\n"
+ "}\n\n"
+ ".backref_hover {\n"
+ " cursor: help;\n"
+ "}\n\n"
+ "input {\n"
+ " blah: blah;\n"
+ "}\n\n"
+ ".stuff {\n"
+ "problem: here;\n"
+ "}\n\n"
+ ".hello\n\n"
+ "{\n\n"
+ "whatever\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}