// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^{}]+{").unwrap();
let string = ".match_num {
font-family: futura, helvetica, arial;
font-variant: small-caps;
color: #84BDE7;
color: #0066B3;
font-size: 12px;
font-weight: normal;
display: inline-block;
}
.match0,.match1,.match2,.match3,.match4,.match5,.match6,.match7,.match8,.match9,.match10,.match11 {
white-space: pre-wrap;
font-size: 12px;
padding: 1px 2px;
}
.backref_hover {
cursor: help;
}
input {
blah: blah;
}
.stuff {
problem: here;
}
.hello
{
whatever
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}