# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^{}]+{"
test_str = (".match_num {\n"
" font-family: futura, helvetica, arial;\n"
" font-variant: small-caps;\n"
" color: #84BDE7;\n"
" color: #0066B3;\n"
" font-size: 12px;\n"
" font-weight: normal;\n"
" display: inline-block;\n"
"}\n\n"
".match0,.match1,.match2,.match3,.match4,.match5,.match6,.match7,.match8,.match9,.match10,.match11 {\n"
" white-space: pre-wrap;\n"
" font-size: 12px;\n"
" padding: 1px 2px;\n"
"}\n\n"
".backref_hover {\n"
" cursor: help;\n"
"}\n\n"
"input {\n"
" blah: blah;\n"
"}\n\n"
".stuff {\n"
"problem: here;\n"
"}\n\n"
".hello\n\n"
"{\n\n"
"whatever\n\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.