package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\.\d+\s+\d+\:\d+`)
var str = `02.01 13:00 выполнено
01.01 12:00 выполнено
01.01 12:00 выполнено 1
02.01 13:00 выполнено 2
01.01 12:00 выполнено 9
02.01 13:00 выполнено 10
01.01 12:00 выполнено 15
02.01 13:00 выполнено 16
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}