use strict;
my $str = '02.01 13:00 выполнено
01.01 12:00 выполнено
01.01 12:00 выполнено 1
02.01 13:00 выполнено 2
01.01 12:00 выполнено 9
02.01 13:00 выполнено 10
01.01 12:00 выполнено 15
02.01 13:00 выполнено 16
';
my $regex = qr/^\d+\.\d+\s+\d+\:\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}