import re
regex = re.compile(r"^\d+\.\d+\s+\d+\:\d+", flags=re.MULTILINE)
test_str = ("02.01 13:00 выполнено\n"
"01.01 12:00 выполнено\n"
"01.01 12:00 выполнено 1\n"
"02.01 13:00 выполнено 2\n"
"01.01 12:00 выполнено 9\n"
"02.01 13:00 выполнено 10\n"
"01.01 12:00 выполнено 15\n"
"02.01 13:00 выполнено 16\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")