re = /^\d+\.\d+\s+\d+\:\d+/m
str = '02.01 13:00 выполнено
01.01 12:00 выполнено
01.01 12:00 выполнено 1
02.01 13:00 выполнено 2
01.01 12:00 выполнено 9
02.01 13:00 выполнено 10
01.01 12:00 выполнено 15
02.01 13:00 выполнено 16
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end