// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\.\d+\s+\d+\:\d+").unwrap();
let string = "02.01 13:00 выполнено
01.01 12:00 выполнено
01.01 12:00 выполнено 1
02.01 13:00 выполнено 2
01.01 12:00 выполнено 9
02.01 13:00 выполнено 10
01.01 12:00 выполнено 15
02.01 13:00 выполнено 16
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}