#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(longword1|longword2)\b.*?\b(?!\1\b)(?1)\b"
Local $sString = "A longword1 B longword2 C" & @CRLF & _
" ^-------------------^" & @CRLF & _
"" & @CRLF & _
"A longword2 B longword1 C" & @CRLF & _
" ^-------------------^" & @CRLF & _
"while these shouldn't:" & @CRLF & _
"" & @CRLF & _
"A longword1 B longword1 C" & @CRLF & _
"A longword2 B longword2 C" & @CRLF & _
"A longword1 B" & @CRLF & _
"A longword2 C"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")