import Foundation
let pattern = #"\b(longword1|longword2)\b.*?\b(?!\1\b)(?1)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A longword1 B longword2 C
^-------------------^
A longword2 B longword1 C
^-------------------^
while these shouldn't:
A longword1 B longword1 C
A longword2 B longword2 C
A longword1 B
A longword2 C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)